Connection to GooglePlay issue

Hi everyone,


I have tried to access SWGOH for the last hour using my usual phone, like I do everyday.

However for any weird reason the game doesn't connect to GooglePlay (all other games still do), and the game starts with the intro cinematic.
Does anyone have already had this issue?

I am a bit worried of loosing my account, as I have playing hours on it (lots of 6* and 7* toons).


Thanks

Replies

  • Options
    Try logging into Google Play. If you were connected to it, your progress will have been saved.

    Hope that helps. :)
  • Triqui
    2790 posts Member
    Options
    Further help:
    I hsve 2 emsils in gmail in my phone, this sometimes happened to me. Go to google play, change your account to 2nd emsil, change it back, and problem solved
  • Options
    I am logged in. I have even try to launch the game from GooglePlay directly, but same issue, starts at level1 ...
    When I access the game description into GooglePlay I can see I have played for a long and winning lots of battle, so the account shouldn't be lost.

  • Triqui
    2790 posts Member
    Options
    Go to google play and untsp the first 3 options (notifications and such).thst's what Customer support says
  • Options
    I can see on the GooglePlay description of the game that many people have suffered this issue since the launch of the new version.
    I just hope it will come back... :(
  • Options
    Problem solved

    If anyone experience this issue:

    I took the risk of playing the tutorial, and once it was finished, I was able to connect to GooglePlay account from the game following the description of this link:

    http://answers.ea.com/t5/Bugs-and-Issues/REGARDING-LOST-ACCOUNTS/m-p/4957819#U4957819
Sign In or Register to comment.