Support for Legacy iOS Devices

CG_SBCrumb
494 posts EA Community Manager
edited August 28
Beginning on September 9th, 2019, in order to accommodate the new features and graphics associated with the game’s next update, Star Wars: Galaxy of Heroes is no longer supported on some legacy iOS devices.

The minimum required iOS version was previously iOS 8.0 and is now iOS 10.0. The list of unsupported devices can be found below. After the update on 9/9, players on unsupported devices will be unable to download the newest version of the game, and the App Store will highlight that their device is unsupported.

At any time before or after the update, players can import their account from an unsupported device to a supported device using their in-game Player ID and/or Ally Code. Your account will still be available and ready to play on a supported device. For more information on how to link your account, please visit Galaxy of Heroes’ EA Help page.

We apologize for the inconvenience.

Impacted Devices
  • iPhone 4S
  • iPad Mini (1st gen)
  • iPad (2nd gen)
  • iPad (3rd gen)
  • iPod (5th gen)
Post edited by CG_SBCrumb on
Sign In or Register to comment.