No Rewards for joining but not posting damage

TK421OKC_SITH
207 posts Member
edited April 7
On 3/25 my guild finished our CPit raid before I got a chance to hit. I had joined, but wasn’t able to hit before they killed it. I got no rewards at all. I sent in this screen shot with my initial ticket to EA on the issue:
lkx2hfy7rjkh.jpeg
FYI I’m TK421 on that photo. After almost 2 weeks of exchanging emails with EA Supoort, in which I had to keep logging back into EA support and adding questions to my case after getting no response for days at a time, today I finally received this from the 3rd different EA Supoort rep:
ah2mi31zeq5b.jpeg
Did I miss something? Is it different than any other raid and if you join but don’t post damage you get squat?

I’m wondering if anyone else has encountered this issue or if I’m the only one getting [email protected]

Replies

  • Had you recently joined the guild?
  • MikKro
    248 posts Member
    Had you recently joined the guild?

    Don't think OP would have been able to even post a 0 in that case.

    Good luck getting anything done with EA Support
  • Kyno
    28658 posts Moderator
    MikKro wrote: »
    Had you recently joined the guild?

    Don't think OP would have been able to even post a 0 in that case.

    Good luck getting anything done with EA Support

    That is not necessarily true, the question is valid to the situation.
  • TVF
    27972 posts Member
    Kyno wrote: »
    MikKro wrote: »
    Had you recently joined the guild?

    Don't think OP would have been able to even post a 0 in that case.

    Good luck getting anything done with EA Support

    That is not necessarily true, the question is valid to the situation.

    If you join the guild after a raid launches you cannot join it.
    The CGDF is recruiting. Say hi in our Discord! https://discord.gg/AmStGTH
  • Yeah, your "damage" is represented by a dash instead of a zero if you don't join the raid.
  • Jkane
    69 posts Member
    Did the other zero damage player get rewards?
  • Kyno
    28658 posts Moderator
    edited April 7
    TVF wrote: »
    Kyno wrote: »
    MikKro wrote: »
    Had you recently joined the guild?

    Don't think OP would have been able to even post a 0 in that case.

    Good luck getting anything done with EA Support

    That is not necessarily true, the question is valid to the situation.

    If you join the guild after a raid launches you cannot join it.

    correct, but the question is still valid. they could have joined recently (to that time), but still outside of the 24 hour window that would cause any issues with joining, and still have too many raids due to the raid schedule in their previous guild.
  • Yes to answer your questions I’ve been in this guild for years and hadn’t left any time recently. I just got another canned “you aren’t eligible” response from EA but no explanation.
Sign In or Register to comment.