GAC bug, this is annoying

fucr
4 posts Member
Hello, has anyone encountered a bug in this game in fleet arena and gac? You pressed battle and then it gets into battle, right there it freezes and there's nothing i could have done. I tried switching wifi but still not good. I had to exit the game and came back to see the first attempt has been recorded. Made me lost the GAC and miss a payout in fleet arena. Why isn't this fixed?

Replies

  • fucr
    4 posts Member
    Options
    @CG_Tusken_Meathead please contact devs this made me angry. It's the game's fault and I still got recorded as a failed attempt. Wasted my good squad
  • Options
    Yes, for my case playing on Apple, specifically on Wampa v GG for some reason. Its cost me 2 GACs within the last two GAC cycles. Idle animations still moving, I can still click buttons like the turn order and the buttons top left, but ability buttons disappear and I can't do anything once that happens. It's annoying as a smaller account going up against bigger accounts if the game freezes and I lose such an important weapon in my roster. CG please acknowledge and fix this!!
Sign In or Register to comment.